首页 > 新闻中心
专业知识

高速焊接工艺

浏览:725次    发布日期: 2017-06-03


路由器的静态路由和动态路由配置。

一、实验目的

(1)了解路由表(2)了解静态路由和动态路由的配置(3)了解RIP和OSPF协议的工作过程

二、应用环境

(1)在小规模环境中,静态路由是最佳选择(2)静态路由成本低,但不灵活,并且用于相对稳定的网络中

三、实验设备

([1) 3个DCR路由器(2) CR-V35FC 1(3) CR-V35MT 1)

四、实验拓扑

静态路由和RIP协议配置的实验拓扑:

OSPF协议配置拓扑:

五、实验要求

配置路由器的IP地址:

路由器A

路由器B

Router-C

F0 / 1

19 2. 16 8. 1. 1

F0 / 1

19 2. 16 8. 2. 1

F0 / 0

19 2. 16 8. 2. 2

F0 / 0

19 2. 16 8. 0. 1

F0 / 0

19 2. 16 8. 1. 2

E0 / 1

19 2. 16 8. 3. 1

六、实验步骤(一)静态路由配置

思科第十一章测试答案_思科3560做接入交换机_思科模拟器做测试

首先更改名称:

同类设备之间的互连使用交叉电缆。

步骤1:请参考先前的实验方法,根据上表配置所有接口的IP地址,确保所有接口都处于up状态,并测试连通性。

首先配置PC1的IP地址,子网掩码和默认网关:

验证PC1:

配置路由器A的IP地址:

RouterA#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
RouterA(config)#int f0/0
RouterA(config-if)#ip address 192.168.0.1 255.255.255.0
RouterA(config-if)#no shutdown
RouterA(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterA(config-if)#exit
RouterA(config)#int f0/1
RouterA(config-if)#ip address 192.168.1.1 255.255.255.0
RouterA(config-if)#no shutdown
RouterA(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
RouterA(config-if)#

别忘了没有关机。

然后验证:

配置路由器B:

RouterB>en
RouterB#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
RouterB(config)#int f0/0
RouterB(config-if)#ip address 192.168.1.2 255.255.255.0
RouterB(config-if)#no shutdown
RouterB(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterB(config-if)#exit
RouterB(config)#int f0/1
RouterB(config-if)#ip address 192.168.2.1 255.255.255.0
RouterB(config-if)#no shutdown
RouterB(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
RouterB(config-if)#exit

检查配置:

配置路由器C:

RouterC>en
RouterC#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
RouterC(config)#int f0/0
RouterC(config-if)#ip address 192.168.2.2 255.255.255.0
RouterC(config-if)#no shutdown
RouterC(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterC(config-if)#exit
RouterC(config)#int f0/1
RouterC(config-if)#ip address 192.168.3.1 255.255.255.0
RouterC(config-if)#no shutdown
RouterC(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
RouterC(config-if)#exit
RouterC(config)#exit

检查配置:

在这里配置后,您可以发现所有配置都已通过:

此外,未配置PC2的IP地址:

然后检查结果:

我们使用PC1对路由器A进行ping操作:

结果可ping通。

Ping路由器B失败。对另一个接口执行Ping操作也会失败,表明目标主机不可访问。

路由器A到ping路由器B澳洲幸运10 ,结果是ping失败:

再次Ping路由器C:

ping也无法实现。但是所有都配置好了,为什么不能ping通?由于未设置路由表,因此可以通过静态路由或动态路由进行设置。动态路由通常使用RIP协议。这里我们首先来看一下静态路由的设置方法。

第2步:检查ROUTER-A的路由表

show ip route

只有两条记录,它们直接相连。第一栏中指出的路线来源:

第3步:检查ROUTER-B的路由表

视图B也直接连接。

第4步:检查ROUTER-C的路由表

对于C也是如此。如果它们都直接连接,那么如果遇到间接连接爱游戏体育网页版 ,他们将不知道如何处理。到目前为止,只有直接连接的机器才能相互通信。我们可以设置静态路由,以使其他设备相互通信。

第5步:在ROUTER-A上PING路由器C

在A上Ping C不能ping

两个接口都无法通信。

步骤6:在路由器A上配置静态路由

使用ip route命令关键字,第一个参数是目标网络地址,第二个参数是目标网络的子网掩码,第三个参数是下一跳的IP地址。

如果路由器A要到达网络19 2. 16 8. 2. 0,则必须由路由器B转发。中间的网络是19 2. 16 8. 1. 0 ,路由器A连接到f0 / 1接口,其IP地址为19 2. 16 8. 1. 1,而路由器的f0 / 0接口为19 2. 16 8. 1. 2路由器A的下一跳应该是路由器B的f0 / 0接口。

因此,如果路由器希望达到19 2. 16 8. 3,则该网络也必须由路由器B和C转发。

在路由器A中进行以下配置:

RouterA(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.2
RouterA(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.2

再次输入show ip route命令以查看一下:

找到了另外两个静态路由。其中[1/0]表示静态路由具有最高优先级。

步骤7:在路由器B和C上配置静态路由

按照相同的方法,我们还在路由器B上配置了一条静态路由:

RouterB(config)#ip route 192.168.0.0 255.255.255.0 192.168.1.1
RouterB(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2

检查配置结果:

又找到了两条静态路由。

以相同的方式,在路由器B上设置一条静态路由鸭脖娱乐官网 ,并同时查看结果:

第8步:配置静态路由后测试结果

使用PC1再次ping通路由器B,并且ping A也可以:****

****使用PC 1 ping路由器C:

发现可以通过ping,这表示静态路由有效。

([二) RIP协议配置

在下面配置RIP协议:

思科模拟器做测试_思科3560做接入交换机_思科第十一章测试答案

还要根据此表进行配置:

第一步:IP地址配置

首先配置PC1的IP地址,子网掩码和默认网关:

验证PC1:

配置路由器A的IP地址:

RouterA#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
RouterA(config)#int f0/0
RouterA(config-if)#ip address 192.168.0.1 255.255.255.0
RouterA(config-if)#no shutdown
RouterA(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterA(config-if)#exit
RouterA(config)#int f0/1
RouterA(config-if)#ip address 192.168.1.1 255.255.255.0
RouterA(config-if)#no shutdown
RouterA(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
RouterA(config-if)#

别忘了没有关机。

然后验证:

这时,我发现其中一部分已经传达:

配置路由器B:

RouterB>en
RouterB#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
RouterB(config)#int f0/0
RouterB(config-if)#ip address 192.168.1.2 255.255.255.0
RouterB(config-if)#no shutdown
RouterB(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterB(config-if)#exit
RouterB(config)#int f0/1
RouterB(config-if)#ip address 192.168.2.1 255.255.255.0
RouterB(config-if)#no shutdown
RouterB(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
RouterB(config-if)#exit

检查配置:

配置路由器C:

RouterC>en
RouterC#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
RouterC(config)#int f0/0
RouterC(config-if)#ip address 192.168.2.2 255.255.255.0
RouterC(config-if)#no shutdown
RouterC(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RouterC(config-if)#exit
RouterC(config)#int f0/1
RouterC(config-if)#ip address 192.168.3.1 255.255.255.0
RouterC(config-if)#no shutdown
RouterC(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
RouterC(config-if)#exit
RouterC(config)#exit

检查配置:

在这里配置后,您可以发现所有配置都已通过:

此外,未配置PC2的IP地址:

然后检查结果:

我们使用PC1对路由器A进行ping操作:

结果可ping通。

Ping路由器B发生故障。

ping另一个接口也失败,表明目标主机不可访问。

第2步:检查路由表

检查ROUTER-A的路由表:

检查ROUTER-B的路由表:

检查ROUTER-C的路由表:

第3步:在ROUTER-A上PING路由器C

我发现现在无法ping通。

第4步:在路由器A上配置RIP协议并查看路由表

route rip
network 192.168.0.0 # 向外通报本路由器的直连路由
netwprk 192.168.1.0

第5步:在路由器B上配置RIP协议并查看路由表

配置B的RIP后:

发现他学到了一条新路由,因为路由器A和路由器B都启用了RIP协议,因此它们可以交换路由信息。

这一次再次查看A,发现还有新的路由记录:

步骤6:在路由器C上配置RIP协议并检查路由表步骤7:再次检查A和B的路由表

路由器A:

路由器B:

第8步:验证配置

RIP的三个要素是:

我们可以清楚地看到通过路由器B的变化,从2到3再到4;

原因很简单,根据固定的时间交换,配置RouterC后立即生效;

由于需要满足三个要素并在固定的时间进行交换思科模拟器做测试,因此收敛需要一定的时间;

区别现在就可以解决;

在路由器A上ping路由器B;

转到ping其他几个网络。

([三) OSPF协议配置

下面配置了OSPF协议。

首先,其拓扑如下:

即将路由器A的f0 / 1接口与路由器B的f0 / 1接口相连,并将IP地址设置为指定的IP。

步骤1:配置路由器A的f0 / 1接口和loopback0接口

输入以下命令进行配置:

Router>en
Router#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int f0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
Router(config-if)#int loopback0
Router(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#en
Router#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname RouterA
RouterA(config)#end
RouterA#
%SYS-5-CONFIG_I: Configured from console by console
RouterA#

记住将名称更改为RouterA:

然后验证:

配置成功,现在去配置路由器B的IP;

步骤2:配置路由器B的f0 / 1接口和loopback0接口

相同的操作:

Router>en
Router#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname RouterB
RouterB(config)#int f0/1
RouterB(config-if)#ip address 192.168.1.2 255.255.255.0
RouterB(config-if)#no shutdown
RouterB(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
RouterB(config-if)#exit
RouterB(config)#int loopback0
RouterB(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
RouterB(config-if)#ip address 10.10.11.1 255.255.255.0
RouterB(config-if)#end

显示运行以验证:

这时,我发现线路已经连接。

这时,它等效于连接到三个网络的两个路由器,但是路由器的路由表中只有直接与之相连的网络。

验证并查看路由表:

路由器A只有两条直接连接的路由思科模拟器做测试,让我们看一下路由器B:

也只有两条直接路线。

第3步:路由器的OSPF配置

我们通过OSPF协议在路由表中交换路由:

首先乐鱼官网 ,路由器A:

route ospf 2	# 2 是进程的标识,可随意取
network 10.10.10.0 255.255.255.0 area 0		# 向外通报自己的路由,必须跟掩码,因为他是有类路由协议
network 192.168.1.0 255.255.255.0 area 0

配置完成后,显示。目前,它没有改变,因为其他路由器没有与他交换路由信息,目前只有他:

这时,我们将修改B的配置信息:

route ospf 2	# 2 是进程的标识,可随意取
network 10.10.10.0 255.255.255.0 area 0		# 向外通报自己的路由,必须跟掩码,因为他是有类路由协议
network 192.168.1.0 255.255.255.0 area 0

这时候,我的眼睛很快澳洲幸运10平台 ,我立即执行show ip route,但是发现仍然只有两个直接路由信息,然后突然弹出一条消息:

00:40:14: %OSPF-5-ADJCHG: Process 3, Nbr 10.10.10.1 on FastEthernet0/1 from LOADING to FULL, Loading Done

这应该提醒您状态更改,因此我再次查看路由表:

发现已经学习了一条新路线。

第4步:检查路由表

我已经成功读取了路由器B的路由表,现在让我们看一下路由器A的信息:

我发现A也将首先给出提示,然后节目中将出现O。

第5步:其他验证命令

验证路由器A:

验证路由器B:

本文参与了腾讯云的自媒体共享计划。如果您正在阅读,欢迎加入并分享。

快乐8体育
分享到:
上一篇:焊割自动化解决方案
下一篇:
返回列表
首页 |  关于我们 |  新闻中心 |  产品中心 |  成功案例 |  联系我们 | 
分享到: